Our upstream network provider reports they resolved the issue. We have not observed any additional network issues over the past hour.
We do not expect any further interruptions to connectivity to the RDU data center.
Posted Jun 05, 2026 - 00:05 PDT
Update
We have seen recovery of remaining connection issues and are continuing to monitor the situation.
Posted Jun 04, 2026 - 22:59 PDT
Update
Some locations still experience connectivity issues to our RDU data center. We also saw a brief period of higher-than-normal packet loss between 2135 and 2141.
Our upstream network providers continue to investigate the connectivity issues.
Posted Jun 04, 2026 - 21:50 PDT
Update
We are continuing to monitor for any further issues.
Posted Jun 04, 2026 - 21:02 PDT
Update
We are continuing to monitor for any further issues.
Posted Jun 04, 2026 - 21:01 PDT
Monitoring
Connectivity to the RDU data center has been restored. We are monitoring to see whether the connectivity issue returns.
The connectivity issue appears related to one of our upstream network providers. We opened a ticket with them and are waiting for them to verify the issue is resolved.
Posted Jun 04, 2026 - 20:55 PDT
Investigating
We are currently experiencing connectivity issues with our RDU datacenter. Our team is investigating the issue and will provide updates as soon as more information becomes available
Posted Jun 04, 2026 - 20:07 PDT
This incident affected: VPS & VPC (RDU Virtual Cluster), Network Infrastructure (RDU Network Infrastructure), and Internet Connectivity (RDU Internet Backbone).