Service Disruption - Power Disruption at BBY

Incident Report for Smartt

Resolved

We have not observed any issues related to the power outage since Thursday, October 16. We consider this incident resolved.

We will send an incident report to our clients via email no later than 1200 PT on Thursday, October 23.
Posted Oct 22, 2025 - 14:50 PDT

Monitoring

We have resolved the DSL internet connectivity outage. We are monitoring for any remaining issues
Posted Oct 15, 2025 - 18:14 PDT

Update

We are still investigate the DSL internet connectivity outage. We currently do not have an ETA for service restoration. We will provide another update by 18:00 PT
Posted Oct 15, 2025 - 17:25 PDT

Update

Our Exchange service has been restored. We are currently investigate the DSL internet connectivity outage. We currently do not have an ETA for service restoration. We will provide another update by 17:00 PT
Posted Oct 15, 2025 - 16:30 PDT

Identified

We are continuing to investigate DSL internet connectivity and Exchange Hosting outage stemming from the Power Outage to our BBY Data Center this morning. We currently do not have an ETA for service restoration. We will provide another update by 16:00 PT
Posted Oct 15, 2025 - 15:24 PDT

Monitoring

Exchange services have been restored. We are monitoring for any remaining issues and working with colocation clients on any remote hands issues.
Posted Oct 15, 2025 - 13:58 PDT

Update

We are currently investigating an issue with Plesk and Exchange hosting.

All other systems have been restored.
Posted Oct 15, 2025 - 13:25 PDT

Update

Hosting services (email, website hosting) have been restored.
Posted Oct 15, 2025 - 13:01 PDT

Update

MagicMail services have been restored.
Posted Oct 15, 2025 - 12:48 PDT

Update

Virtual hosting infrastructure service has been restored. We are now restoring individual services (mail, webhosting, VPS/VPC).
Posted Oct 15, 2025 - 12:47 PDT

Update

We are currently working on restoring virtual cluster services.

Colocation services have been restored.
Posted Oct 15, 2025 - 12:33 PDT

Update

We are currently working on restoring shared services.

DNS service has been restored.
Posted Oct 15, 2025 - 12:01 PDT

Update

We are seeing issues with colocation internet connectivity and our internal office network and are investigating.
Posted Oct 15, 2025 - 11:25 PDT

Update

Internet connectivity has been restored - we are now working on bringing up component services.
Posted Oct 15, 2025 - 11:03 PDT

Update

We are continuing our efforts to restore network connectivity and will continue to provide updates on our progress as soon as possible.
Posted Oct 15, 2025 - 11:00 PDT

Update

Update: We are working to restore network connectivity at this time, and will focus on restoring affected services once network access has been restored.
Posted Oct 15, 2025 - 10:29 PDT

Update

Generator service is online - we are currently powering up systems to restore services.

BC Hydro outage is still ongoing.
Posted Oct 15, 2025 - 09:57 PDT

Update

Update: Our generator contractor is onsite and is investigating our backup generator.

Regional power restoration (Per BC Hydro Power Outage update site) is estimated to be completed by 12:00 PT.

Link to BC Hydro Outage Report: https://www.bchydro.com/power-outages/app/outage-map.html#outage=2652048
Posted Oct 15, 2025 - 09:54 PDT

Identified

Update: We have confirmed that our upstream power has been affected by a general power outage in the region. However, our internal generator failed to take over the workload. Maintenance contractors are en-route, with ETA of 15 minutes.
Posted Oct 15, 2025 - 09:30 PDT

Investigating

We are currently experiencing a power outage at the BBY location. All systems are currently offline. We are currently investigating and will be providing updates within the next 15 minutes.
Posted Oct 15, 2025 - 09:26 PDT
This incident affected: Internet Connectivity (BBY Primary Internet Backbone, BBY Secondary Internet Backbone), Network Infrastructure (BBY Network Infrastructure), Shared Hosting (cPanel, Plesk, DNS, MagicMail, Microsoft Exchange), and VPS & VPC (BBY Virtual Cluster).