MagicMail major version upgrade(22nd March 2026)

Scheduled for Mar 22, 23:00 PDT  -  Mar 23, 00:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 05, 2026 - 19:50 PST

Scheduled

We will be performing a MagicMail version upgrade, and a downtime of approximately 45–60 minutes is expected. During this time, there may be brief interruptions to mail services lasting 10–60 seconds, but no significant customer impact is anticipated.
Posted Mar 05, 2026 - 19:48 PST
This scheduled maintenance affects: Shared Hosting (MagicMail).