BBY VM Infrastructure Upgrades (September 2025)

Scheduled for Sep 20, 21:00 PDT  -  Sep 21, 08:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 29, 2025 - 09:59 PDT

Scheduled

We will upgrade the virtualization platform in our BBY virtualization infrastructure.

Client services may see some downtime during the upgrade when we upgrade the networking components. We expect no more than five minutes of downtime
Posted Aug 28, 2025 - 15:09 PDT
This scheduled maintenance affects: Internet Connectivity (BBY Primary Internet Backbone), Network Infrastructure (BBY Network Infrastructure), Shared Hosting (cPanel), and VPS & VPC (BBY Virtual Cluster).