BBY Scheduled Maintenance - PSU Replacement (February 2026)

Scheduled for Feb 13, 20:00 - 20:10 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 12, 2026 - 09:17 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 12, 2026 - 09:16 PST

Scheduled

We will be performing the following maintenance activities:

We will be replacing a failing PSU in at the BBY colocation center

Expected downtime: 10 minutes
Posted Feb 12, 2026 - 09:15 PST
This scheduled maintenance affects: Network Infrastructure (BBY Network Infrastructure).